Back to overview
Planning Center service restored
Jan 17, 2024 at 3:21am UTC
Affected services
servewireapp.com
Resolved
Jan 17, 2024 at 3:21am UTC
We have restored the connection to Planning Center.
Affected services
Resolved
Jan 17, 2024 at 3:21am UTC
We have restored the connection to Planning Center.
Affected services